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1.0 Overview of C-Temp 

1.1 What is C-Temp? 
 

Congratulations on purchasing the C-Temp Temperature Monitoring 
System. C-Temp enables temperature input information to be displayed and 
monitored easily and effectively. C-Temp is a ‘C-Com Enabled’ 
application, which means it makes use of the C-Com server to gather any 
temperature information that is entering the system via the computer’s 
communications ports. The following manual outlines the features of the C-
Temp system and how it can be used to efficiently service any temperature 
monitoring needs. 
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1.2 System Requirements 
 
 C-Temp operates under Microsoft Windows 98, Windows ME or 
Windows NT™ on IBM™ or compatible personal computers (PC’s). The 
minimum system requirements for C-Temp are: 
 

• CPU: Intel™ Pentium Processor, 400MHz or better 
• RAM: 32 Mb 
• 256 colour Windows compatible graphics driver 
• At least 1 serial communications port 
• Mouse or Trackball pointing device 

 

1.3 Item Check List 
 
 The following list details the items that you should have received 
as part of the C-Temp product pack. 
 

9 1 x CD-ROM containing the necessary files to install C-Temp. 
9 1 x Operating instruction book. 
9 1 x Serial Temperature transducer. 
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2.0 The Main Window 
 

The Main Window, as the name suggests, represents the core 
component of C-Temp. The window is comprised of eight areas of interest 
as shown in Figure 1. These areas will be discussed in more detail in the 
following sections. 

1. Main Menu 
2. Main Temperature Display 
3. Alarm Settings 
4. Trend Indicator 

5. Temperature Graph 
6. Positional Information 
7. Status Display 
8. Celsius/Fahrenheit Button

 

 
Figure 1. 

2.1 The Main Menu 
 

The Main Menu provides access to a number of useful secondary 
windows. An expanded view outlining the structure of the Main Menu is 
shown in Figure 2. The ‘File’ Menu allows the application to be closed. All 
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of the Secondary windows can be accessed via the ‘View’ Menu. The 
‘Help’ Menu accesses the ‘About’ window, which contains information 
about C-Temp. The Secondary windows will be discussed in more detail in 
section 3.0. 

 

 
Figure 2. 

 
The ‘Minimal View’ menu item resizes the Main Window so that 

only the Main Menu, Main Temperature, GPS Position, Alarm Settings, 
and Temperature Status Displays are showing. This enables C-Temp to 
have less of a screen presence allowing other applications to be seen 
effectively. When C-Temp is in minimal mode, the ‘Minimal View’ menu 
item changes to ‘Expanded View’. This allows easy toggling between the 
two displays. 

 

2.2 The Main Temperature Display 
 

As the name suggests this area of the Main Window displays the 
temperature currently being monitored, as a numeric value. The 
temperature units for this display can be toggled using the 
‘Celsius/Fahrenheit’ button (see section 2.8). The Main Temperature 
Display also shows the name of the temperature currently being monitored 
(i.e. Water Temperature, Air Temperature, etc). The temperature name can 
be modified through the ‘Options’ window (see section 3.2). 

 

2.3 Alarm settings 
 

This area of the Main Window displays the current state of the 
alarm settings. It shows if the alarm is ‘SET’ or ‘OFF’ and the High and 
Low alarm limits. These settings can be altered in the ‘Alarm Settings 
Window’. This can be accessed by choosing View → Settings → Alarm in 
the Main Menu, or simply clicking on any of the parameters in the Alarm 
Settings area of the main display window. 
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2.4 Temperature Trend Indicator 
 

This indicates the current trend of the temperature input. It has three 
states: 

 
1. Stable – Denoted by the word ‘STABLE’. 
2. Rising – Denoted by a red coloured up arrow. 
3. Falling – Denoted by a blue coloured down arrow. 

2.5 Temperature Graph 
 

The Temperature Graph plots trends in the temperature over time. 
The default ‘Time Scale’ is 10 minutes. This means that the entire width of 
the graph shows the last 10 minutes of temperatures with a frequency of 1 
reading every ten seconds. Time Scales of 1 hour, 12 Hours and 24 Hours 
can also be displayed (See ‘The Options Window’ section). 

 
Each point on the graph can be queried by simply clicking on the 

desired point (the cursor will change to a hand ). Doing this will display 
an Information window, as shown in Figure 3, that displays the 
Temperature, the Offset, the Time, and the GPS Position for the selected 
point. 

 
 

 
Figure 3. 

 



TMQ C-Temp V1.01 9  27/07/01 

2.6 The GPS Position Display 
 

This area of the Main Window displays the current GPS Position of 
the vessel. If the GPS input has been set to ‘None’, this area will remain 
blank. 

2.7 Temperature Status Display 
 

The Temperature Status Display provides a visual display of the 
status of the system. The display can contain any one of the following 
phrases given the appropriate circumstances. 

 
o Temperature Normal – As expected this indicates that the 

system is running error free, and that the temperature is between 
the set limits if the alarm is ‘SET’. If the alarm is ‘OFF’ this will 
be displayed even when the temperature is outside of the alarm 
limits. 

o Temperature Alert! – This is displayed when the alarm is 
‘SET’ and the temperature being monitored has moved outside 
of the alarm limits. An audible message will also sound to 
indicate that a breach of alarm limits has occurred. 

o No Temperature Data! – This is a fairly straightforward 
message and is usually accompanied by a similar audible alert. 
If this message is encountered, check the Setup configuration 
and the connection of the temperature sensor to the computer. 

o No GPS Data! – This occurs if the GPS input has been set 
up, however no data has been received from this device for at 
least 10 seconds. This is also accompanied by a similar audible 
alert. 

2.8 Celsius/Fahrenheit Button 
 

Clicking on this button changes the temperature units from Celsius 
to Fahrenheit and vice versa. The units will be changed in the Main 
Temperature Display, the Alarm Settings Display, and on the Temperature 
Graph. 
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3.0 Secondary Windows 
 

Secondary windows allow such things as the alarm settings to be 
changed, the temperature and GPS inputs to be configured, etc. Each of C-
Temps secondary windows will be discussed in turn. 

 

3.1 Alarm Settings Window 
 

This window can be 
accessed by either choosing 
View→Settings→Alarm in the 
Main menu or clicking on any of 
the parameters in the Alarm 
settings area of the Main Display 
Window. 

This window allows the 
Alarm to be activated/deactivated 
and the high and low alarm limits 
can be set. To turn the alarm on, 
simply check the ‘Alarm On’ 
checkbox by clicking on the 
square. If a tick appears in this 
square ( ), the alarm has been 

‘SET’. Clicking this box when the alarm is on will deactivate the alarm. 
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 The high and low alarm limits can be set, simply by clicking the 
appropriate Up/Down arrow. Each click on an arrow will change the alarm 
limit by 0.1 of a degree when in ‘Celsius’ units. 
 

Once the limits have been set click the ‘Apply’ button to accept the 
changes. A line corresponding to each limit will appear on the Temperature 
Graph at the appropriate temperature setting (A Red line for High and a 
blue line for low). 
 
 Note: The High alarm limit cannot be set lower than the Low alarm limit 
and vice versa. The alarm limit lines only appear on the Temperature 
Graph if the value of the limit is between those being displayed on the 
temperature axis. 

3.2 Options Window 
 

 
 
This window can be accessed by either choosing View → Settings 

→ Options in the Main Menu, clicking on the Temperature Graph, or 
clicking on the Temperature Name above the Main Temperature Display. 

 
This window allows Temperature Graph options to be set, along 

with a temperature offset (calibration). The ‘Time Scale’ field can be set to 
one of four values, 10 min, 1 hour, 12 hours and 24 hours. This time 
represents the amount of time shown on the time axis of the Temperature 
graph. The ‘Chart Title’ field allows the title of the Temperature Graph to 
be altered.  

 



TMQ C-Temp V1.01 12  27/07/01 

Changing the chart title will also change the Temperature name in 
the Main Temperature Display and the associated temperature name in the 
temperature source list on the ‘Setup Window’. The chart title should not 
be longer than 30 characters, including spaces. The ‘Display Chart Title’ 
checkbox can hide or show the Title on the Temperature Graph, however 
the Temperature Name in the main display is always visible. 

 
Once the desired changes have been made to the options clicking 

the ‘Apply’ button will save these changes. Clicking the ‘Cancel’ button 
will close the window without making changes to the options. 

3.3 Setup Window 
 

 
 

This window can only be accessed by choosing View→Setup in 
the Main Menu. 

The ‘Setup Window’ allows the Temperature and GPS inputs to be 
assigned. If the GPS source is set to ‘None’, the GPS Position area on the 
Main Window will be blank. Any changes made to the Chart Title from the 
options window will affect the name of the current temperature in the 
temperature source list. Once the desired input choices have been made, 
click the ‘Apply’ button for these settings to take effect. 

 
 Note: These Setup options do not require communications port 
information. This information should be set on the ‘Serial Setup’ page of C-
Com. If there are any problems regarding receiving Temperature or GPS 
data, please consult the C-Com User manual. 
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TMQ C-Com Communications Server 

 
User Manual 

 
 C-Com enables full control of a systems communication ports, 
such as COM1. The application enables incoming data to be shared 
amongst all C-Com Enabled TMQ applications. C-Com allows effortless 
monitoring and configuration of all data inputs. All user settings are saved 
and hence modification of the configuration of C-Com should only need to 
be done when new hardware is connected to the system, or when the 
current hardware input of the system has been modified. C-Com can also 
aid in diagnosing any input related errors that may occur during the normal 
operation of the system. The following manual outlines the features of the 
C-Com server and how it can be used to efficiently integrate input data for 
use by all C-Com Enabled Applications. 
 

1.0 Exploring the Main Window 
 

 
 
The main window of C-Com contains the majority of features 

required to effectively configure the systems data inputs. C-Com consists of 
a Main window and a Communication Port configuration window 
(discussed in a later section). The user interface is very easy to use with a 
row of labelled tabs toward the top of the window (see Figure 1). Clicking 
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on any one of these tabs reveals the information associated with that 
particular tab. 
 

In the bottom right-hand corner of the main window is the ‘Hide’ 
button, this button allows C-Com to run in the background (i.e. No screen 
presence). In order to render the main window visible, simply double-click 
on the TMQ Communications Server icon ( ) in the System Tray. The 
following sections will outline each of the main window tabs and the 
information displayed. 

 
 
 

 
The System Tray 

(Bottom right corner of the screen). 
 

 
1.1 The NMEA Data Tab 

 
The NMEA Data tab (See Figure 1) is simply a displayed summary of 

the configured inputs. The display is in the form of a table with 5 labelled 
columns. 

 
o Type – This column contains the types of data that have 

been configured in C-Com. 
o Data – This column contains the actual value of the data 

that is being received. 
o Age – This column displays the age of the data in seconds. 

Whenever new data is received and the Data column for 
that particular ‘Type’ is refreshed and the ‘Age’ display is 
reset to zero. 

o Source – This column indicates the NMEA sentence that 
is being used as the source of the particular Type of data. 

o Comm Port – This column indicates the communications 
port that has been configured to receive a particular 
NMEA sentence. 

 
If there is a problem with receiving any type of data, the first sign on 

the C-Com display, will be an increasing Age for the data. Once the data 
has reached a certain age it is removed from this table. 
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1.2 The Target Information Tab 
 

 
Figure 2 

 
The Target Information tab display is much the same as the NMEA Data 

tab display. However, this tab displays information on various types of targets. 
There are three different types of targets represented on this display, TTM Targets, 
TLL Targets, RDM Targets, Ryokuseisha and Taiyo. Each of these target types is 
displayed in its own table (see figure 2). In order to view a particular Target Table, 
simply click the desired table in the box above the table. The targets are displayed 
in order of Target Number and, as with the NMEA Data display, when a target’s 
age reaches a certain value the target is removed from the table.  
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1.3 The Input Configuration Tab 
 
The Input Configuration tab allows the NMEA Source and 

Communications Port for each Type of data to be configured. In addition it allows 
the NMEA sentence to be checked for reliability (CSS & VCS). 

 
This tab is comprised of two key areas, the Configuration table & the 

configuration modification section. The Configuration table displays the current 
configuration settings, while the configuration modification section allows the 
settings of the highlighted data type (Configuration Table) to be altered.  

1.3.1 The Configuration Table  
 

The first column of the configuration table (Data) lists all the possible data 
types that can be configured via C-Com. The next two columns, Source and NMEA 
Type display the current communications port and NMEA sentence settings. If 
these are ‘None’ it means that the data type in question has not yet been 
configured. The final two columns CSS (Check Sentence Structure) and VCS 
(Verify Check Sum) display the status of the reliability verification parameters. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Figure 3. 
o Check Sentence Structure (CSS): This option configures C-Com to 

check the particular NMEA Sentence to ensure it has the correct 
sentence structure (i.e. The correct number of fields). This can 
improve the reliability of the system by discarding sentences that may 
have been corrupted while being transmitted between devices. 

o Verify Check Sum (VCS): This option configures C-Com to verify the 
check sum of the NMEA sentence in question. This method is far 
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more reliable than the CSS method, unfortunately contrary to the 
NMEA Standard 0183, many companies fail to include a check sum in 
their sentences and in these cases the VCS feature should not be set. 

 
1.3.2 Configuration Modification Section 

 
 This section is made up of everything else that appears on this 

tab apart from the configuration table. The first fields to identify are those marked 
Data, Source & NMEA Type. These fields relate directly to the first three columns 
of the table. When a row in the configuration table is highlighted, the information 
in the above mentioned fields reflect that of the highlighted row. It is now possible 
to modify the configuration of the highlighted row. The Source and NMEA Type 
can be modified via the drop down lists (The data field cannot be modified). The 
two check boxes below allow the CSS and VCS checks to be turned on or off. If 
the check box is ‘checked’ the associated check is ‘ON’, and vice versa. 

 
 Once the desired changes have been made in the configuration 

modification section click the Apply button to apply these changes to the 
Configuration Table. Continue making changes until all desired Data types are 
configured then click the Accept All button. Once Accept All has been clicked the 
configuration displayed in the configuration Table will take effect. Check the 
NMEA Data tab to ensure that all of the configured Data types are being received 
correctly. If the Reset button is clicked, instead of the Accept All button, the 
configuration will return to settings that were established the last time Accept All 
was clicked. A flowchart outlining the input configuration procedure can be found 
in the accompanying documentation. 
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1.4 Output Configuration Tab 
 

Figure 4. 
 
The Output Configuration Tab allows the manner, in which C-Com 

outputs data, to be configured. It is organised in the same way as the Input 
Configuration Tab. The Output Configuration Table contains two columns Data 
and Destination.  Similarly the Configuration Modification section has both Data 
and Destination fields. Only the Destination field can be modified through the use 
of the drop down list. 

 
To configure an output to a device, simply choose the appropriate 

communications port for the desired device and click Apply. As with Input 
Configuration once all the desired devices have been provided with destination 
communication ports, click Accept All to accept the displayed configuration, or 
Reset to return to the settings saved when Accept All was last clicked. 
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1.5 Serial Setup Tab 
 

 
 
The Serial Setup tab allows the individual communications ports to be 

configured. Each communications port has a check box marked Active, a field that 
displays the current configuration settings and a Configure button. The Active 
check box allows the associated communications port to be started or stopped 
(Checked = Started, Unchecked = Stopped). The configuration display field simply 
displays the current configuration; it cannot be modified from this field. In order to 
modify the configuration settings for communications port simply click the 
Configure button of the associated port. 

 Once the Configure button has been clicked a dialog box will appear. 
Select the desired setting form the drop down list 
can set each of the fields. Once the desired 
modifications have been made click the Apply 
button. To cancel configuration of the 
communications port at any time, click Cancel. 
Click on the Default Settings button to return the 
configuration settings to the default values (i.e. 
4800 bps, 8 Data Bits, Parity – ‘None’, 1 Stop Bit 
and Flow Control – ‘None’). 

Place a ‘check’ in the box for ‘Data 
access type  Non Standard Serial Port’ if data is 
not received on the serial port. Check for data 

using the ‘Serial I/O’ tab with the correct Com port selected. 
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1.5.1  C-Panel / C-Temp Special Configuration Information. 
 

 
When configuring the C-Panel to enable external alarms or two way 

communication with some types of GPS antenna it may be necessary to place a 
‘Check’ ( ) in the ‘Data access type  Non Standard Serial Port’ box for the 
configuration of that port. This should be done if the C-Panel does not produce an 
audible alarm signal when C-Plot is displaying an alarm, for example; C-Plot may 
be alarming due to an incorrect direction for a GOTO and the C-Panel isn’t 
‘Beeping’.  

When connecting a C-Temp probe do not place a ‘Check’ in the ‘Data 
access type  Non Standard Serial Port’ box. 

Under certain circumstances the C-Temp probe may need resetting if 
temperature data is not present. This can be achieved via the C-Com 
communications server. Select the ‘Serial Setup’ tab then deactivate the 
Com port that the temperature probe is connected to. Leave deactivated for 
5 seconds and reactivate in again, this will reset the temperature probe. 

 
 
 
 
 
 
 
 
 
 
 
 

Communication Port Configuration Dialog Box 
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1.6 Serial I/O Tab 
 

 
 
The Serial I/O Tab allows the input and output data streams to be 

monitored. Simply click the desired communications port in the CommPorts box, 
to display the raw data being received and sent via this port. This is a useful tool to 
use when configuring the Input and Output settings of C-Com. Clicking on the 
‘Stop!’ selection will prevent the data from scrolling up the screen so that it can be 
comfortably analysed. 

 

 

 

2.0 Summary 
 
C-Com is a powerful and productive tool allowing C-Com Enabled 

TMQ applications to share the communications ports effectively. A set of 
flowcharts is provided to enable C-Com to be used efficiently. These 
flowcharts outline such procedures as Input Configuration, Output 
Configuration and adding new devices to the system. 
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TMQ C-Com Communications Server 
Quick Setup for C-Temp 

 
This is intended as a quick guide / check procedure for the C-Temp 
settings. 
 

1. Open C-Temp from the Desktop icon. Open C-Com by double left 
mouse clicking the ( ) icon at bottom right corner of the screen. 

 
2. Select the ‘Serial Setup’ tab. 

• Activate the Com Port that the temperature probe is 
connected to by placing a ‘tick’ in the ‘Active’ box. 

• If unsure of Com Port activate all possible Com Ports. 
• Check the Com Port configuration 4800,N,8,1,N (Default) 

 
3. Select the ‘Serial I/O’ tab. 

• Select the Com Port that the temperature probe is 
connected to from the list on the left side of the window. 

• If unsure of Com port select one at a time to find DATA. 
• NMEA Data should be seen in the ‘Input Data’ window. 

(eg. $YCMTW,025.59,C) 
• Select ‘Serial I/O’ tab and deactivate the other Com Ports 

previously activated if not required for other input devices. 
 

4. Select the ‘Input Configuration’ tab. 
• Scroll down the input ‘Data’ list to ‘Temperature 1’, left 

mouse click on it. 
• Select the Com Port that the temperature sensor is 

connected to (eg. COM1) from the ‘Source’ box. 
• Select MTW from the ‘NMEA Type’ box. 
• Left mouse click the ‘Accept’ box.  

 
5. Hide the C-Com Server. 

• Left mouse click the ‘Hide’ button. 
 

6. Temperature data should now be displayed in C-Temp. 
• If temperature data is not displayed in C-Temp check the 

connections and the above setup. 


